Windows 8.1 / IE11 FTP Bug!

  • Advertisement ( why? )
     

    Wishmaster, 29th Mar 2015 9:09 pm

    As I upgraded to Win 8.1 and started using HTML-Kit at the same time, I thought HTML-Kit has a problem with FTP.
    Even though I setup the ftp idle timeout of the server to 2 hours(!) I'm getting a timeout in HTML-Kit after a few minutes.

    googeling for "window 8.1 ftp problem" frings up a huge amount of angry users of several different programs which use ftp and having problems under windows 8.1.

    I tried HTML-Kit on two different Windows 7 machines where the problem does not come up!

    In fact, the problem seems to rely on an updated wininet(.dll) which comes with Internet Explorer 11.
    Windows 8(.0) and Windows 7 users can uninstall IE11 and downgrade to IE10, but Win 8.1 users don't have this possibility as Win 8.1 comes with IE11 and there is no way to downgrade.

    Please have a look:
    https://www.youtube.com/watch?v=hF7nS2hZFp8
    http://bit.ly/1Dal5fT
    http://bit.ly/1Dalhf2

    In the YT video above, the developers of their software implemented an option to switch the ftp engine to winsock, which seems to resolve the issue.

    As Win 8.1 is getting more and more used, do you think you can find any solution for this problem?

    At least, HTML-Kit does not become unusable (like other programs), but it's still very annoying that I have to wait a fair amount of time before the ftp connection is reestablished after working a few minutes on a file without saving every minute.

    Thanks in advance.

    • HTML-Kit Support, 30th Mar 2015 11:32 am

      On 3/29/2015 9:09 PM, Wishmaster wrote:

      As I upgraded to Win 8.1 and started using HTML-Kit at the same
      time, I thought HTML-Kit has a problem with FTP.
      Even though I setup the ftp idle timeout of the server to 2 hours(!)
      I'm getting a timeout in HTML-Kit after a few minutes.

      googeling for "window 8.1 ftp problem" frings up a huge amount of
      angry users of several different programs which use ftp and having
      problems under windows 8.1.

      I tried HTML-Kit on two different Windows 7 machines where the
      problem does not come up!

      In fact, the problem seems to rely on an updated wininet(.dll) which
      comes with Internet Explorer 11.
      Windows 8(.0) and Windows 7 users can uninstall IE11 and downgrade to
      IE10, but Win 8.1 users don't have this possibility as Win 8.1 comes
      with IE11 and there is no way to downgrade.

      Please have a look:
      https://www.youtube.com/watch?v=hF7nS2hZFp8
      http://bit.ly/1Dal5fT
      http://bit.ly/1Dalhf2

      In the YT video above, the developers of their software implemented
      an option to switch the ftp engine to winsock, which seems to resolve
      the issue.

      As Win 8.1 is getting more and more used, do you think you can find
      any solution for this problem?

      At least, HTML-Kit does not become unusable (like other programs),
      but it's still very annoying that I have to wait a fair amount of
      time before the ftp connection is reestablished after working a few
      minutes on a file without saving every minute.

      Thanks in advance.

      Hi,

      That's interesting... I haven't had a chance to take a deep dive but
      wanted to let you know that I'll follow up.

      Chami

      • Wishmaster, 6th Apr 2015 7:33 pm

        Do you use wininet.dll for FTP functions?
        I tested it on a Win 7 machine with Internet Explorer 11 which shows up the same problems like under Win 8.1.

        Could it be a quick fix, to first look for a wininet.dll in den HTML-Kit program folder and use this one (which could be replaced with an older version than Win 8.1 uses from C:\windows\system32)?!

        (wysiwygwebbuilder.com used this workaround)

        • HTML-Kit Support, 6th Apr 2015 7:48 pm

          On 4/6/2015 7:33 PM, Wishmaster wrote:

          Do you use wininet.dll for FTP functions?
          I tested it on a Win 7 machine with Internet Explorer 11 which shows
          up the same problems like under Win 8.1.

          Could it be a quick fix, to first look for a wininet.dll in den
          HTML-Kit program folder and use this one (which could be replaced
          with an older version than Win 8.1 uses from C:\windows\system32)?!

          (wysiwygwebbuilder.com used this workaround)

          I'm going to sound like the Grinch... but I'm not sure if this is a good
          solution.

          I know that FTP timing out can be frustrating and I'm not dismissing
          your concerns. Let me see if there's a way to reduce the delay when it's
          reconnecting to a known host, as in reconnecting to a host within the
          same session.

          Is your FTP server inside your local network or is it at an external web
          host?

          Chami

          • Wishmaster, 6th Apr 2015 9:39 pm

            It's external.

            • HTML-Kit Support, 7th Apr 2015 8:04 am

              On 4/6/2015 9:39 PM, Wishmaster wrote:

              It's external.

              I'll try and post a TreeHouse build today to help speed up reconnects.

              Chami

              • HTML-Kit Support, 7th Apr 2015 1:46 pm

                On 4/7/2015 8:04 AM, HTML-Kit Support wrote:

                On 4/6/2015 9:39 PM, Wishmaster wrote:

                It's external.

                I'll try and post a TreeHouse build today to help speed up
                reconnects.

                Chami

                TreeHouse build 20150325 is in http://www.htmlkit.com/assistant/

                Let me know if you see any improvement in FTP reconnect speed.

                Chami

                • Wishmaster, 7th Apr 2015 7:04 pm

                  THANKS!
                  I downloaded and installed it.
                  I'll give you a feedback within the next days.

                • Wishmaster, 9th Apr 2015 6:30 pm

                  Looks like it still looses the connection, but reconnection speed is MUCH(!) better now!
                  Thanks a lot for your support Chami.

                  It's not frustating any more and I can live with it now.
                  But perhaps you can keep the connection loosing issue in mind, when you don't know what to do/code else. ;-)

                  • HTML-Kit Support, 10th Apr 2015 12:33 pm

                    On 4/9/2015 6:30 PM, Wishmaster wrote:

                    Looks like it still looses the connection, but reconnection speed is
                    MUCH(!) better now!
                    Thanks a lot for your support Chami.

                    It's not frustating any more and I can live with it now.
                    But perhaps you can keep the connection loosing issue in mind, when
                    you don't know what to do/code else. ;-)

                    Yay! Dancing on the streets :)

                    Thanks for checking it out and getting back.

                    Chami