win7 ie9 - when i pick preview in ie it always opens a new window

  • Advertisement ( why? )
     

    patyoung, 2nd Jan 2013 5:13 am

    not a tab. is this a quirk of ie9 ?
    also, when it opens the new window, there is a message at the bottom saying ie blocked this program from running scripts, allow them ?

    is this just me, or typical behavior ?

    • HTML-Kit Support, 2nd Jan 2013 4:48 pm

      Hi,

      On 1/2/2013 5:13 AM, patyoung wrote:

      not a tab. is this a quirk of ie9 ?
      also, when it opens the new window, there is a message at the bottom
      saying ie blocked this program from running scripts, allow them ?

      is this just me, or typical behavior ?

      It's not just you. This is the typical behavior but you can adjust IE's
      default settings to allow running scripts for local files under Internet
      Options > Security.

      There are at lest three ways you can make it easier to preview in IE...

      1. If you prefer to use F8, adjust IE's settings to allow scripting, etc.

      2. Enable IE preview mode on Preview tab (F12) in HTML-Kit Tools using
        "Add IE Preview."

      3. Use Extended Preview. This is my preferred way of testing pages in
        multiple browsers. Click the monitor icon on the right-hand side of the
        menu bar to enable Extended Preview. Then open the preview URL in IE and
        any other browsers. When you edit and press F12 in Tools, the associated
        browsers will automatically update with the latest changes.

      Hope this helps.

      Chami

      • patyoung, 3rd Jan 2013 10:07 am

        chami -

        i implemented option 3, and as you said, it got the browser responding correctly. but when i press f12 to update the browser, it also flips the editor view to preview, which is very distracting.

        • patyoung, 3rd Jan 2013 10:38 am

          if i hit f12 twice, it solves the problem. thanks.