UTF-8 without byte order mark

  • Advertisement ( why? )
     

    rodfarias, 1st Mar 2014 7:44 pm

    Hello.
    Does anyone know if there is any way to save my utf-8 encoded files without byte order mark at top?
    Thank you very much, I could not find this feature (if possible).
    Rodrigo.

    • HTML-Kit Support, 1st Mar 2014 8:00 pm

      On 3/1/2014 7:44 PM, rodfarias wrote:

      Hello.
      Does anyone know if there is any way to save my utf-8 encoded files
      without byte order mark at top?
      Thank you very much, I could not find this feature (if possible).
      Rodrigo.

      Hi Rodrigo,

      Once you make sure that BOM is disabled under "Edit > Preferences >
      Files > Encoding," any of the following methods can be used to save in
      UTF-8 without the byte order mark:

      • "File > Save As > Encoding"
      • Change encoding on document status bar
      • Make UTF-8 the default under "Edit > Preferences > Files > Encoding"

      And of course don't forget to select UTF-8 when opening those files
      since it won't know for sure without the BOM.

      Chami

      • rodfarias, 2nd Mar 2014 9:11 am

        Changing the preference is the solution. (It was easy, sorry for being distracted.)
        I do notice that the first option ("File> Save As> Encoding") no longer exists since you added the encoding selection in the status bar.

        Thank you very much.
        Rodrigo

        • HTML-Kit Support, 2nd Mar 2014 10:03 am

          On 3/2/2014 9:11 AM, rodfarias wrote:

          Changing the preference is the solution. (It was easy, sorry for
          being distracted.)
          I do notice that the first option ("File> Save As> Encoding") no
          longer exists since you added the encoding selection in the status
          bar.

          It's on the Save As dialog itself next to Quick Picks and Line Ending Mode.

          Thank you very much.
          Rodrigo

          No prob :)

          Chami

          • rodfarias, 2nd Mar 2014 10:18 am

            OK.

            I don't know if it was my problem or it may occur to another, but I had to expand the window's 'Save As..' dialogue pulling the bottom right corner, and then lost combos reappeared.

            Thanks again.