Unwanted opening of BAT file

  • Advertisement ( why? )
     

    Charles, 7th Aug 2012 7:35 pm

    HTML-Kit Tools for Windows 20120801
    Windows 7 Home Premium Edition Version 6.1 (Build 7600), 64-bit/WOW64
    IE 9.0.8112.16421, COMCTL32 6.16, SHELL32 6.1.7600.25177, 50727
    1,834,220 KB out of 4,153,716 KB of physical memory available.
    .NET Framework 2.0.50727.4971 (r) / v2.0.50727 (clr) / 2.0 SP2, 3.0 SP2,
    3.5 SP1, 4.0 (i)
    Monitor: (0, 0, 1366, 768), 32 bpp

    Chami,

    Don't know if this is a Tools problem or a Windows problem. Since
    installing Tools (not this last version, much earlier versions) when a
    bat file is called to execute, the file opens instead in Html Kit Tools.
    I edited the Preferences Files to remove bat from the file list yet it
    continues to happen.

    I found in the Windows files associations that bat is to be opened by HK
    Tools. But I am at a loss to indicate what program should be used to
    execute these types of files. File type cmd is also assigned to HK
    Tools which I would question for the same reason.

    It seems that these associations should not be. Any suggestions on what
    to do?

    (The US Postal Service has a program for labeling and postage printing.
    There is a batch file included in the update to cover the increase of
    postage prices. It will not update because the bat file is opened
    rather than executed.)

    Charles

    • HTML-Kit Support, 7th Aug 2012 9:58 pm

      On 8/7/2012 7:35 PM, Charles wrote:

      HTML-Kit Tools for Windows 20120801
      Windows 7 Home Premium Edition Version 6.1 (Build 7600), 64-bit/WOW64
      IE 9.0.8112.16421, COMCTL32 6.16, SHELL32 6.1.7600.25177, 50727
      1,834,220 KB out of 4,153,716 KB of physical memory available.
      .NET Framework 2.0.50727.4971 (r) / v2.0.50727 (clr) / 2.0 SP2, 3.0 SP2,
      3.5 SP1, 4.0 (i)
      Monitor: (0, 0, 1366, 768), 32 bpp

      Chami,

      Don't know if this is a Tools problem or a Windows problem. Since
      installing Tools (not this last version, much earlier versions) when a
      bat file is called to execute, the file opens instead in Html Kit Tools.
      I edited the Preferences Files to remove bat from the file list yet it
      continues to happen.

      I found in the Windows files associations that bat is to be opened by HK
      Tools. But I am at a loss to indicate what program should be used to
      execute these types of files. File type cmd is also assigned to HK
      Tools which I would question for the same reason.

      It seems that these associations should not be. Any suggestions on what
      to do?

      (The US Postal Service has a program for labeling and postage printing.
      There is a batch file included in the update to cover the increase of
      postage prices. It will not update because the bat file is opened
      rather than executed.)

      Charles

      Hi Charles,

      HTML-Kit doesn't override these settings so this probably isn't related
      to an update.

      What may have happened though is that HTML-Kit may have been set as the
      default program, for example, in the Control Panel. HTML-Kit doesn't do
      this on its own, it's just how associations work in Windows user interface.

      I don't know if there's an easy way to reset file associations using the
      Windows GUI. Here's how to do it with RegEdit (all warnings about
      editing the registry applies)...

      • In Windows Start menu, search for regedit.exe and open it.

      • Look for a key named "UserChoice" under:

        HKEY_CURRENT_USER\
        Software\Microsoft\Windows\CurrentVersion\Explorer\
        FileExts\ .bat

      • Delete UserChoice (only UserChoice inside the above key for ".bat")

      • Close RegEdit and try opening a .bat file

      Hope this helps.

      Chami

      • Charles, 8th Aug 2012 10:43 am

        On 8/7/2012 10:58 PM, HTML-Kit Support wrote:

        On 8/7/2012 7:35 PM, Charles wrote:

        HTML-Kit Tools for Windows 20120801
        Windows 7 Home Premium Edition Version 6.1 (Build 7600), 64-bit/WOW64
        IE 9.0.8112.16421, COMCTL32 6.16, SHELL32 6.1.7600.25177, 50727
        1,834,220 KB out of 4,153,716 KB of physical memory available.
        .NET Framework 2.0.50727.4971 (r) / v2.0.50727 (clr) / 2.0 SP2, 3.0 SP2,
        3.5 SP1, 4.0 (i)
        Monitor: (0, 0, 1366, 768), 32 bpp

        Chami,

        Don't know if this is a Tools problem or a Windows problem. Since
        installing Tools (not this last version, much earlier versions) when a
        bat file is called to execute, the file opens instead in Html Kit Tools.
        I edited the Preferences Files to remove bat from the file list yet it
        continues to happen.

        I found in the Windows files associations that bat is to be opened by HK
        Tools. But I am at a loss to indicate what program should be used to
        execute these types of files. File type cmd is also assigned to HK
        Tools which I would question for the same reason.

        It seems that these associations should not be. Any suggestions on what
        to do?

        (The US Postal Service has a program for labeling and postage printing.
        There is a batch file included in the update to cover the increase of
        postage prices. It will not update because the bat file is opened
        rather than executed.)

        Charles

        Hi Charles,

        HTML-Kit doesn't override these settings so this probably isn't related
        to an update.

        What may have happened though is that HTML-Kit may have been set as the
        default program, for example, in the Control Panel. HTML-Kit doesn't do
        this on its own, it's just how associations work in Windows user interface.

        I don't know if there's an easy way to reset file associations using the
        Windows GUI. Here's how to do it with RegEdit (all warnings about
        editing the registry applies)...

        • In Windows Start menu, search for regedit.exe and open it.

        • Look for a key named "UserChoice" under:

          HKEY_CURRENT_USER\
          Software\Microsoft\Windows\CurrentVersion\Explorer\
          FileExts\ .bat

        • Delete UserChoice (only UserChoice inside the above key for ".bat")

        • Close RegEdit and try opening a .bat file

        Hope this helps.

        Chami

        Chami,

        Thanks. After editing the registry as you said fixed the problem. The
        update of the postal program now successfully concludes.

        Charles

        • HTML-Kit Support, 10th Aug 2012 2:23 pm

          On 8/8/2012 10:43 AM, Charles wrote:
          ...

          Chami,

          Thanks. After editing the registry as you said fixed the problem. The
          update of the postal program now successfully concludes.

          Charles

          Great! I'm glad it helped.

          Chami

    • Maglor, 8th Aug 2012 6:01 am

      In windows 7 go to control panel>Default Programs>Set Associations and scroll down to .bat double click .bat and if HTML-Kit is the registered program remove the check mark Always use the selected program to open this kind of file

      Nigel

      • Charles, 8th Aug 2012 10:45 am

        On 8/8/2012 7:01 AM, Maglor wrote:

        In windows 7 go to control panel>Default Programs>Set Associations and scroll down to .bat double click .bat and if HTML-Kit is the registered program remove the check mark Always use the selected program to open this kind of file

        Nigel

        Nigel,
        Yes, the box is checked but it is grayed out so it can't be changed.

        Thanks for offering your suggestion.

        Charles

      • Charles, 8th Aug 2012 10:45 am

        On 8/8/2012 7:01 AM, Maglor wrote:

        In windows 7 go to control panel>Default Programs>Set Associations and scroll down to .bat double click .bat and if HTML-Kit is the registered program remove the check mark Always use the selected program to open this kind of file

        Nigel

        Nigel,
        Yes, the box is checked but it is grayed out so it can't be changed.

        Thanks for offering your suggestion.

        Charles