Tidy changes accented characters to other special characters, not to html entities

  • Advertisement ( why? )
     

    cmpsalvestrini, 12th Jun 2012 10:14 am

    The latest version of HTML Kit Tools, which I had been using without incident in another computer, behaves erratically in a new installation. Specifically: Tidy replaces accented characters with other accented characters instead of changing them to HTML entities.

    • HTML-Kit Support, 12th Jun 2012 11:36 am

      On 6/12/2012 10:14 AM, cmpsalvestrini wrote:

      The latest version of HTML Kit Tools, which I had been using without
      incident in another computer, behaves erratically in a new
      installation. Specifically: Tidy replaces accented characters with
      other accented characters instead of changing them to HTML entities.

      Hi,

      It sounds like what you're seeing is the UTF-8 encoding of accented
      characters.

      If you prefer to keep raw characters (though UTF-8 is a valid and
      generally recommended encoding), you can customize Tidy to output
      Latin-1 or raw characters as shown in this video (you want latin1
      instead of utf8) :

      http://www.htmlkit.com/go/info/tools/tidy-config

      This is the setting for Latin-1:

      output-encoding: latin1

      Tidy will keep any HTML entities that you already have in HTML documents.

      http://www.w3.org/International/O-charset.en.php

      "The examples above show declarations for UTF-8 encoded content. This is
      likely to be the best choice of encoding for most purposes, but it is
      not the only possibility.

      If not using UTF-8 you should replace the utf-8 text in the examples
      above with the name of the encoding you have chosen."

      Hope this helps.

      Chami