Thai language support

  • Advertisement ( why? )
     

    dickcox, 23rd Feb 2014 1:42 pm

    When I paste Thai characters in the edit window, they display correctly, but in the preview window, they are displayed as question marks. Anyone know how to correct this?

    Thanks.

    • HTML-Kit Support, 23rd Feb 2014 6:46 pm

      On 2/23/2014 1:42 PM, dickcox wrote:

      When I paste Thai characters in the edit window, they display
      correctly, but in the preview window, they are displayed as question
      marks. Anyone know how to correct this?

      Thanks.

      Hi,

      This usually means there's a mismatch in character encoding. I'd try this...

      Make sure that the HTML document is saved in UTF-8. It doesn't have to
      be that particular encoding but without a good reason to do otherwise
      I'd use UTF-8. You can make UTF-8 the default using "Edit > Preferences

      Files > Encoding > UTF-8."

      Then indicate the character encoding used by your document by adding
      charset meta tag to the head section:

       <meta charset="utf-8">
      

      That should do the trick. If the document is already open, you can pick
      character encoding on "File > Save As" dialog.

      Chami