Paste doesn't work.

  • Advertisement ( why? )
     

    Shano, 10th Mar 2014 12:23 pm

    I recently updated to HTML-Kit Tools version 20131106 and Windows 8.1. The program won't paste source code. Ctrl-C works, but Ctrl-V does not. Nor can I paste using the paste function in the edit drop-down menu. This makes HTML-Kit Tools limited for writing HTML and not very useful for writing PHP code or CSS files. What is the fix for this?

    • HTML-Kit Support, 10th Mar 2014 12:30 pm

      On 3/10/2014 12:23 PM, Shano wrote:

      I recently updated to HTML-Kit Tools version 20131106 and Windows
      8.1. The program won't paste source code. Ctrl-C works, but Ctrl-V
      does not. Nor can I paste using the paste function in the edit
      drop-down menu. This makes HTML-Kit Tools limited for writing HTML
      and not very useful for writing PHP code or CSS files. What is the
      fix for this?

      Hi,

      Paste works of course. I couldn't use HTML-Kit Tools at all if it didn't :)

      Now let's find out why it's not working for you on your system. What
      background programs are you running, including anti-virus? Do you have
      easy access to another computer where you could try Tools just as a
      comparison?

      Chami

      • Shano, 18th Mar 2014 12:15 am

        Thanks, Chami.

        For the first 2 days after I installed HTML-Kit Tools on my new Window 8 computer, I couldn't make paste work for anything. Even rebooting my computer didn't help. I had some urgent work to do, so I did without it for a week.

        Now I tried it, and paste works every time, even when all the programs I use are running. I think that goes in my paranormal file.

        I had been using HTML-Kit Tools for a couple of years on a Windows 7 computer without any such incident. When I changed computers, the only program I changed was virus protection. I went from McAfee to Webroot.

        Shano

        • Shano, 18th Mar 2014 3:05 am

          My HTML-Kit Tools again got into a state where paste didn't work. Restarting the program didn't help. I found that if I turn off Webroot real time anti-virus protection and then turn it on again, the paste function in HTML-Kit Tools is restored. It's not a paranormal experience after all.

          Shano

          • HTML-Kit Support, 18th Mar 2014 12:17 pm

            On 3/18/2014 3:05 AM, Shano wrote:

            My HTML-Kit Tools again got into a state where paste didn't work.
            Restarting the program didn't help. I found that if I turn off
            Webroot real time anti-virus protection and then turn it on again,
            the paste function in HTML-Kit Tools is restored. It's not a
            paranormal experience after all.

            Shano

            Hi Shano,

            Even though I had a feeling something was blocking copy/paste outside of
            HTML-Kit, I didn't know exactly what or why. Thanks to your follow-up I
            think we've solved this mystery!

            I installed Webroot and started copying and pasting in various programs.
            It all worked fine even when Webroot is turned all the way up to 11. So
            I opened the browser to read your post but thought I'd try pasting one
            more time before replying. And then it happend!

            It turns out, Webroot blocks copy/paste when a browser is open,
            apparently to protected screen content. Their forum has a "Clipboard
            copy blocked by Webroot when web browser is running" thread with more
            information.

            In short, you can allow clipboard access in Webroot under "Identity
            Protection settings > Application Protection."

            Thanks again for your feedback!

            Chami