Not saving to HTML by default...

  • Advertisement ( why? )
     

    SaintRoch, 11th Aug 2012 10:04 am

    I don't "think" I was having this problem when I 1st started using the application maybe a month ago...

    For the last couple of weeks files are being save with no extension.

    "Save as" defaults to ALL FILES. ????

    I tried to find some preferences to set (and in fact may have messed something up even more), but nothing helps.

    Also, is there a way to keep the menu on the right from coming up whenever I launch? I tried to find a preference setting for that as well...

    Thank you.

    Cane

    • HTML-Kit Support, 11th Aug 2012 11:07 am

      Hi Cane,

      On 8/11/2012 10:04 AM, SaintRoch wrote:

      I don't "think" I was having this problem when I 1st started using
      the application maybe a month ago...

      For the last couple of weeks files are being save with no extension.

      "Save as" defaults to ALL FILES. ????

      I tried to find some preferences to set (and in fact may have messed
      something up even more), but nothing helps.

      When it defaulted to "All Files (.)", what type of file were you
      saving? HTML-Kit Tools tries to default to the most likely file type for
      you, and then settles on All Files if it can't find a good match.

      Also, is there a way to keep the menu on the right from coming up
      whenever I launch? I tried to find a preference setting for that as
      well...

      Please make sure that "Show Start Window" and "Reopen windows" are set
      to No, under "Edit > Preferences > General > Startup."

      Thank you.

      Cane

      You're welcome. Hope this helps!

      Chami

      • SaintRoch, 13th Aug 2012 12:45 pm

        Hi Chami-

        Last things 1st. Setting the "Edit, Preferences...> did it.
        Sorry I couldn't find it on my own.

        I always work with HTML - don't know anything about other types.

        I believe this may be related to the previous problem we discussed: crashing and not erasing preview files.

        It might be useful for you to know that I have been using files from a shared folder created by another user. (The other user is me, but I setup a different user for my business.)

        Today I have moved all the HTML files from the other user's shared folder to a folder of my own. (Confused yet.)

        Many thanks,
        Cane

        • SaintRoch, 13th Aug 2012 12:50 pm

          Hi Chami-

          Late breaking news.

          I just opened a HTML file from my new non-shared folder, erased one line, and selected SAVE AS so I could give it a new name.

          It defaulted to ALL FILES and I had to select HTML from the pull-down.

          I had another file to do the same thing to and the same thing happened.

          v.20120801
          Win7

          Thanks,
          Cane

          • HTML-Kit Support, 13th Aug 2012 1:15 pm

            On 8/13/2012 12:50 PM, SaintRoch wrote:

            Hi Chami-

            Late breaking news.

            I just opened a HTML file from my new non-shared folder, erased one
            line, and selected SAVE AS so I could give it a new name.

            It defaulted to ALL FILES and I had to select HTML from the
            pull-down.

            I had another file to do the same thing to and the same thing
            happened.

            v.20120801
            Win7

            Thanks,
            Cane

            I'm still puzzled. It should select the appropriate file type.

            Is "Edit > Preferences > Advanced > General > Windows 7 style open/save
            dialogs" disabled by any chance?

            Chami

            • SaintRoch, 14th Aug 2012 11:35 am

              No, it's enabled.

              I feel almost "good" about being able to puzzle you.<g>

              Do you think a CLEAN reinstall would help?

              Odd thing is (to me anyway) v. 292 is not having the same problem.

              Thank you for everything.

              Cane

              • HTML-Kit Support, 14th Aug 2012 11:48 am

                On 8/14/2012 11:35 AM, SaintRoch wrote:

                No, it's enabled.

                I feel almost "good" about being able to puzzle you.<g>

                Could you send me some Rogaine while you're at it :)

                Do you think a CLEAN reinstall would help?

                Odd thing is (to me anyway) v. 292 is not having the same problem.

                Thank you for everything.

                Cane

                You don't have to reinstall but you could try "Factory Settings" option
                that's on the drop-down menu for Preferences icon. This way you can
                revert to your custom settings just as easily. If this doesn't help,
                could you maybe send me a pic of the file open dialog?

                Chami

                • SaintRoch, 16th Aug 2012 1:21 pm

                  Headaches: Free
                  Rogaine: Extra Charge

                  Set to factory settings.

                  I will send the file...

                  Thanks,
                  Cane

                  • SaintRoch, 31st Jan 2013 11:40 am

                    Hi Chami!

                    Any chance you remember what you did to fix this?

                    I bought a new computer and the same thing is happening.

                    I just loaded and edited 20 - 30 .html files and they were all saved as generic.

                    (Anyone know a way to change these all to .hmtl in a batch?)

                    Thanks,
                    Cane

                    • HTML-Kit Support, 31st Jan 2013 12:19 pm

                      On 1/31/2013 11:40 AM, SaintRoch wrote:

                      Hi Chami!

                      Any chance you remember what you did to fix this?

                      I bought a new computer and the same thing is happening.

                      I just loaded and edited 20 - 30 .html files and they were all saved as generic.

                      (Anyone know a way to change these all to .hmtl in a batch?)

                      Thanks,
                      Cane

                      Hi,

                      I still don't know why it's saving in plain text for you if you open a
                      *.html file and press Ctrl+S. It should just save in that same file name
                      as it does for me.

                      For new files (File > New), you can type .html at the end when you enter
                      a new file name (File > Save As).

                      As for renaming files, this might be the more straightforward way
                      (though not a batch rename): open Windows Explorer and change to the
                      folder where you have these files. Select a file and press F2 to rename
                      it. Recent versions of Windows automatically place the caret before the
                      extension which should make it a bit easier to do this.

                      Chami

                      • SaintRoch, 7th Feb 2013 1:37 pm

                        Hi Chami-

                        Last Summer you and I had a TeamViewer session and you changed something on my computer that made it work.

                        I wish I could remember the words you used...I cannot.

                        This is a whole new computer and a whole new installation.

                        I just can't imagine what kind of thing this is that followed over to a new computer.

                        Thanks.

                        Cane

                        • HTML-Kit Support, 13th Feb 2013 9:53 am

                          On 2/7/2013 1:37 PM, SaintRoch wrote:

                          Hi Chami-

                          Last Summer you and I had a TeamViewer session and you changed
                          something on my computer that made it work.

                          I wish I could remember the words you used...I cannot.

                          This is a whole new computer and a whole new installation.

                          I just can't imagine what kind of thing this is that followed over to
                          a new computer.

                          Thanks.

                          Cane

                          Hmmm... I was trying to think... did we maybe change the list of file types?

                          Please try this and let me know what happens:

                          1. Select "File > Open from > Open with File Name Filter > Edit"

                          2. Make sure that the default item is selected on the left-hand side

                          3. In the editor window on the right-hand side, scroll down to the <i
                            ... /> tag with "HTML Documents"

                          4. Cut the whole <i ... /> tag with l="HTML Documents"

                          5. Paste it below <d index="7" /> at the top

                          6. Click OK to save changes and reopen HTML-Kit Tools

                          Does this help any?

                          Chami

                          • SaintRoch, 14th Feb 2013 4:03 pm

                            Hi Chami-

                            I got mixed results from that...AND I messed something up trying - when I tried to open files HTML-Kit Tools was looking for COLD FUSION! (I don't even know what that is.)

                            So, I reinstalled and that seems to have worked.

                            Even thought this was a new installation last Fall, I probably installed it before I restored my old HD. And, for a while I was using files straight from the restoration folder.

                            For me to be the only one with this problem, and on essentially two different computers, I MUST have had something cross-wired in my folders.

                            I also use several profiles and had probably installed HTML-Kit Tools from a different one than I commonly use it in.

                            NOW all my files are in the proper profile, AND I installed HTML-Kit Tools in that profile.

                            Thanks, as always, for your kind support.

                            Cane