KT won't recognize edited images

  • Advertisement ( why? )
     

    patyoung, 15th Jan 2013 1:17 pm

    i have changed the canvas size of several images. faststone and irfanview see the modified images with no trouble, but Kit Tools can't see them. is this a quirk of the program ?

    i have tried saving the modified .jpg's as .bmp's, but still no luck.

    • Dave P, 15th Jan 2013 1:59 pm

      On 1/15/2013 2:17 PM, patyoung wrote:

      i have changed the canvas size of several images. faststone and irfanview see the modified images with no trouble, but Kit Tools can't see them. is this a quirk of the program ?

      i have tried saving the modified .jpg's as .bmp's, but still no luck.

      After you change the size of your images, are you recreating the tags
      for them? An image tag has the width and height of the image in the
      tag. If the old width and height are still in your tag they will
      display at the old size.

      Also, .bmp's will not work in web pages. Your images should be .jpg,
      .gif or .png only

      Dave Pyles

      • HTML-Kit Support, 15th Jan 2013 2:09 pm

        On 1/15/2013 1:59 PM, Dave Pyles wrote:

        On 1/15/2013 2:17 PM, patyoung wrote:

        i have changed the canvas size of several images. faststone and
        irfanview see the modified images with no trouble, but Kit Tools can't
        see them. is this a quirk of the program ?

        i have tried saving the modified .jpg's as .bmp's, but still no luck.

        After you change the size of your images, are you recreating the tags
        for them? An image tag has the width and height of the image in the
        tag. If the old width and height are still in your tag they will
        display at the old size.

        Also, .bmp's will not work in web pages. Your images should be .jpg,
        .gif or .png only

        Dave Pyles

        Hi Dave,

        Good point about updating image tag dimensions.

        Sorry, I didn't see your reply when I posted mine.

        Chami

    • HTML-Kit Support, 15th Jan 2013 2:06 pm

      On 1/15/2013 1:17 PM, patyoung wrote:

      i have changed the canvas size of several images. faststone and
      irfanview see the modified images with no trouble, but Kit Tools
      can't see them. is this a quirk of the program ?

      i have tried saving the modified .jpg's as .bmp's, but still no
      luck.

      Hi,

      I'd keep them in .jpg format or convert to .png if you want lossless
      compression because .bmp is not a web-friendly image format.

      HTML-Kit image picker should see the new images without a problem
      though. How exactly do you mean that it's not seeing them?

      Chami

      • patyoung, 15th Jan 2013 2:35 pm

        Thank you both for your speedy replies.
        when you say re-create the image tag, are you talking about the <img> in my HTML doc, or
        something that is a part of the image itself ?

        when i made the new image, i re-named it and used that new name in my html.

        when i say it won't see it, i mean that it yields an empty frame with the little generic image icon in it.
        also, when i reference an image (in the html doc) that KT can find, it shows a thumbnail of it when i hover. but it won't with these modified images.

        it is not just any modified image. i have cropped and re-sized/re-sampled without problems many times. but i believe this is the first time i have extended the width of an image using change canvas.

        • patyoung, 15th Jan 2013 2:37 pm

          this probably doesn't matter, but while i am waiting for my re-placement video card i am using KT in safe mode. just thought i would mention it.

        • Dave P, 15th Jan 2013 2:52 pm

          On 1/15/2013 3:35 PM, patyoung wrote:

          Thank you both for your speedy replies. when you say re-create the
          image tag, are you talking about the <img> in my HTML doc, or
          something that is a part of the image itself ?

          when i made the new image, i re-named it and used that new name in my
          html.

          when i say it won't see it, i mean that it yields an empty frame with
          the little generic image icon in it. also, when i reference an image
          (in the html doc) that KT can find, it shows a thumbnail of it when i
          hover. but it won't with these modified images.

          it is not just any modified image. i have cropped and
          re-sized/re-sampled without problems many times. but i believe this
          is the first time i have extended the width of an image using change
          canvas.

          Yes, I meant to recreate the <img> tag in your HTML doc after you resize
          the image.

          Is the image being saved in the same folder after you increase the
          canvas size? IrfanView uses the last use folder for the image type when
          you select Save as...

          Dave Pyles

          Dave Pyles

          Make sure that you are saving your images in a web-friendly format.
          Also, check to see that the

        • Charles, 15th Jan 2013 3:02 pm

          On 1/15/2013 3:35 PM, patyoung wrote:

          Thank you both for your speedy replies.
          when you say re-create the image tag, are you talking about the <img> in my HTML doc, or
          something that is a part of the image itself ?

          when i made the new image, i re-named it and used that new name in my html.

          when i say it won't see it, i mean that it yields an empty frame with the little generic image icon in it.
          also, when i reference an image (in the html doc) that KT can find, it shows a thumbnail of it when i hover. but it won't with these modified images.

          it is not just any modified image. i have cropped and re-sized/re-sampled without problems many times. but i believe this is the first time i have extended the width of an image using change canvas.

          If you simply changed the name of the image file in the img tag then it
          is still using the dimensions created for the original image. Do one of
          two: Change the width and height dimension to the new size or re-insert
          the new image via the image picker.

          While sometimes it does not result in the best looking image, you can
          just change the dimensions within the img tag and it will display at
          that size. Reductions are better than enlargements.

          Charles

          • patyoung, 15th Jan 2013 3:47 pm

            i checked out both of the image editors to see about saving in a web-friendly format (the first i've heard of it), and faststone doesn't seem to offer it. but irfanview does if i use a plug-in i don't have (and don't want to try to install while i am restricted to safe mode). i tried in paint, but web friendly is not offered. in paint i saved as a .png, no luck. re-named to a single word (no spaces), no luck.

            yes, i tried changing the dimensions in the img tag. no luck. it just doesn't see the file.

            • patyoung, 15th Jan 2013 3:55 pm

              in doing a little reading, aren't .jpg and .png already web friendly formats ?

              • HTML-Kit Support, 15th Jan 2013 4:04 pm

                On 1/15/2013 3:55 PM, patyoung wrote:

                in doing a little reading, aren't .jpg and .png already web friendly formats ?

                Yes, JPEG, GIF and PNG are web-friendly image formats. What I meant was
                that BMP shouldn't be used for images used on the web.

                Chami

              • HTML-Kit Support, 15th Jan 2013 4:17 pm

                On 1/15/2013 3:55 PM, patyoung wrote:

                in doing a little reading, aren't .jpg and .png already web friendly
                formats ?

                I just got your email with .jpg and .png images. Both show up fine in
                preview so I'd make sure that they're in the correct folder. IMG tags
                should look something like:

                 <img src="screenblue.jpg" width="1680" height="150" alt="..." />
                

                Chami

                • patyoung, 15th Jan 2013 5:01 pm

                  well thanks all. i have come to the conclusion that it is a video card issue (and i am using an old on-board video - in safe mode).

                  believe me, i have verified that the modified problem files are in the same folder. i had saved them to the same file, and they are still there. and when i substitute the next door file (next alphabetically), that image displays fine.

                  at least it wasn't be being so dumb as to not call on the right directory. new video card due yet this week, so i'll see then.

                  thanks again

                  • Charles, 15th Jan 2013 9:21 pm

                    On 1/15/2013 6:01 PM, patyoung wrote:

                    well thanks all. i have come to the conclusion that it is a video card issue (and i am using an old on-board video - in safe mode).

                    believe me, i have verified that the modified problem files are in the same folder. i had saved them to the same file, and they are still there. and when i substitute the next door file (next alphabetically), that image displays fine.

                    at least it wasn't be being so dumb as to not call on the right directory. new video card due yet this week, so i'll see then.

                    thanks again

                    When you write, "i am using an old on-board video - in safe mode" that
                    implies to me you are working in Windows safe mode. In Windows safe
                    mode much of the system that is normally used, such as drivers, are
                    disabled. I would not recommend running applications in safe mode.

                    Or am I not understanding.

                    Charles

            • Dave P, 15th Jan 2013 4:26 pm

              On 1/15/2013 4:47 PM, patyoung wrote:

              i checked out both of the image editors to see about saving in a
              web-friendly format (the first i've heard of it), and faststone
              doesn't seem to offer it. but irfanview does if i use a plug-in i
              don't have (and don't want to try to install while i am restricted to
              safe mode). i tried in paint, but web friendly is not offered. in
              paint i saved as a .png, no luck. re-named to a single word (no
              spaces), no luck.

              yes, i tried changing the dimensions in the img tag. no luck. it just
              doesn't see the file.

              Web friendly formats are .png, .jpg and .gif. Most other formats won't
              work well on the web. Most image editors won't offer a filter for
              "web-friendly, but the above 3 file types arethe only ones you should use.

              Is the new file in the same folder as the old file?

              Dave Pyles

              • patyoung, 15th Jan 2013 5:06 pm

                just out of curiosity, have you tried extending an image width by adding a color rectangle to the right using canvas, and then opened it in KT ?

                • Dave P, 15th Jan 2013 5:44 pm

                  On 1/15/2013 6:06 PM, patyoung wrote:

                  just out of curiosity, have you tried extending an image width by adding a color rectangle to the right using canvas, and then opened it in KT ?

                  I did. Works fine here.
                  Dave Pyles

                  • patyoung, 15th Jan 2013 11:54 pm

                    ok. thanks for checking. if my new video card doesn't do the trick, i guess i'll have to reload KT.

                    • Charles, 16th Jan 2013 9:36 am

                      On 1/16/2013 12:54 AM, patyoung wrote:

                      ok. thanks for checking. if my new video card doesn't do the trick, i guess i'll have to reload KT.

                      I don't see how the video card could prevent you from displaying a
                      static image of different size. I can see how the cache could easily
                      present this problem, but you say you have a different name for the
                      image. Do you have it up loaded so others can see what is in your html
                      file?

                      Charles