Images not showing in preview from remote folder

  • Advertisement ( why? )
     

    LiseD, 6th Aug 2012 10:16 pm

    So I have started a new project, and I got the local website folder in it, as well as setting up and accessing the remote folder in ftp.

    It's the same files in both folders, and when I open a page in the remote folder, the file opens fine, but when I preview, the images and style information don't show up. They do if I open the page in the local file, and the website is coming up fine online. As near as I can tell all the files are in the same places in both cases (CSS and HTML files in one folder, with images in their own folder inside that)...

    any ideas?

    __Lise

    • HTML-Kit Support, 7th Aug 2012 7:21 am

      On 8/6/2012 10:16 PM, LiseD wrote:

      So I have started a new project, and I got the local website folder
      in it, as well as setting up and accessing the remote folder in ftp.

      It's the same files in both folders, and when I open a page in the
      remote folder, the file opens fine, but when I preview, the images
      and style information don't show up. They do if I open the page in
      the local file, and the website is coming up fine online. As near as
      I can tell all the files are in the same places in both cases (CSS
      and HTML files in one folder, with images in their own folder inside
      that)...

      any ideas?

      __Lise

      Hi Lise,

      You can tell Tools where to look for resources when previewing through a
      remote server by setting "Base URL for Previewing" shown here:

      http://www.htmlkit.com/view/#!/i/hkt-ftp-preview-url-1

      Depending on how your FTP folder is structured, you may also have to set
      "Initial Path" which is on the "Advanced" tab. But try the above by
      itself first.

      Hope this helps.

      Chami

    • Charles, 7th Aug 2012 10:26 am

      On 8/6/2012 11:16 PM, LiseD wrote:

      So I have started a new project, and I got the local website folder in it, as well as setting up and accessing the remote folder in ftp.

      It's the same files in both folders, and when I open a page in the remote folder, the file opens fine, but when I preview, the images and style information don't show up. They do if I open the page in the local file, and the website is coming up fine online. As near as I can tell all the files are in the same places in both cases (CSS and HTML files in one folder, with images in their own folder inside that)...

      any ideas?

      __Lise

      Most likely source of problem preventing images from displaying is path.
      The best way to avoid this problem is on start of a web page,
      immediately save it to a local folder which duplicates that as it will
      be used at the remote service. Html Kit (292 and Tools) will then write
      the path correctly. If this is the problem and only problem, then you
      will not be the only one who ever had this to occur.

      Charles

      • LiseD, 7th Aug 2012 8:42 pm

        Umm... the only "advanced" tab I've been able to find is in the preferences section of the Edit tab - and that doesn't seem to have what you are talking about. Where do I find this window? Did I mention I am using Tools?

        __Lise

        • LiseD, 7th Aug 2012 9:02 pm

          Oh, found it. :

          "edit settings" Under the remote folder I set up in the project folders. apparently the URL I have, though it gets me access, isn't the Base URL, so I can't try this until I get that info... Thanks

          ___Lise

          • HTML-Kit Support, 8th Aug 2012 8:03 am

            On 8/7/2012 9:02 PM, LiseD wrote:

            Oh, found it. :

            "edit settings" Under the remote folder I set up in the project
            folders. apparently the URL I have, though it gets me access, isn't
            the Base URL, so I can't try this until I get that info... Thanks

            ___Lise

            If index.html (or the default page for the root of your website) isn't
            in the first level when you open the FTP folder, you may just need to
            set the "Initial Path" in Advanced tab.

            For example, if your FTP folder has a "wwwroot" subfolder (this can be
            anything depending on host) where your public website files are stored,
            you can try adding that to the Initial Path. When you do that, the
            preview will know to grab http://yoursite/index.html instead of
            http://yoursite/wwwroot/index.html

            Hope this helps.

            Chami