HTML-Kit Tools Crashing...

  • Advertisement ( why? )
     

    SaintRoch, 22nd Jun 2012 7:37 am

    I just upgraded from the free version which always worked reliably for me.

    For no apparently consistent reason HTML-Kit Tools throws the following message:


    HTML-Kit Tools Editor

    HTML-Kit Tools Editor has encountered a user-defined breakpoint.

    Windows is checking for a solution to the problem...


    Windows, of course, doesn't find a solution.

    My code is simple and unsophisticated - all I do is cut and paste into my eBay site. All the files I am working with were created in, and working fine in, HTML-Kit 292. I have about 30 almost identical files and I am adding one or two lines to each one. After opening/editing/closing 5 or 6 files I get dumped out with the above message.

    Thanks for any help.

    Win7
    4GB RAM
    90 GB HD Free

    • HTML-Kit Support, 22nd Jun 2012 7:59 am

      On 6/22/2012 7:37 AM, SaintRoch wrote:

      I just upgraded from the free version which always worked reliably
      for me.

      For no apparently consistent reason HTML-Kit Tools throws the
      following message:


      HTML-Kit Tools Editor

      HTML-Kit Tools Editor has encountered a user-defined breakpoint.

      Windows is checking for a solution to the problem...


      Windows, of course, doesn't find a solution.

      My code is simple and unsophisticated - all I do is cut and paste
      into my eBay site. All the files I am working with were created in,
      and working fine in, HTML-Kit 292. I have about 30 almost identical
      files and I am adding one or two lines to each one. After
      opening/editing/closing 5 or 6 files I get dumped out with the above
      message.

      Thanks for any help.

      Win7
      4GB RAM
      90 GB HD Free

      Hi,

      Are you getting these errors while previewing? Could you also please
      post (or email -- htmlkit.com/contact/) detailed version information
      from "Help > About?" If you don't mind emailing me one of the files
      you're working on, that might also be helpful since I haven't gotten
      other reports of this.

      Chami

      • SaintRoch, 25th Jun 2012 10:34 am

        HTML-Kit Tools for Windows 20120605
        Windows 7 Home Premium Edition Version 6.1 (Build 7601: Service Pack 1)
        IE 9.0.8112.16421, COMCTL32 6.16, SHELL32 6.1.7601.35583, 50727
        1,526,496 KB out of 2,097,152 KB of physical memory available.
        .NET Framework 2.0.50727.5456 (r) / v2.0.50727 (clr) / 2.0 SP2, 3.0 SP2, 3.5 SP1, 4.0 (i)
        2 monitors (0, 0, 2560, 1024): (0, 0, 1280, 1024), 32 bpp; (1280, 0, 2560, 1024), 32 bpp

        Previewing...could be...good question...I'm copying/pasting/previewing/closing/opening so fast I wasn't paying attention. BUT, I was going to ask about the PREVIEW files that showed up in the directory where I store the files I create. I assumed that was a feature and tried to find a way to turn it off. Now I'm thinking they aren't supposed to be there.

        I erased them all so I can't tell you anymore about them. I will send you one of the files I was working on.

        Thank you, Chami!

        • HTML-Kit Support, 25th Jun 2012 10:51 am

          On 6/25/2012 10:34 AM, SaintRoch wrote:

          HTML-Kit Tools for Windows 20120605
          Windows 7 Home Premium Edition Version 6.1 (Build 7601: Service Pack 1)
          IE 9.0.8112.16421, COMCTL32 6.16, SHELL32 6.1.7601.35583, 50727
          1,526,496 KB out of 2,097,152 KB of physical memory available.
          .NET Framework 2.0.50727.5456 (r) / v2.0.50727 (clr) / 2.0 SP2, 3.0 SP2, 3.5 SP1, 4.0 (i)
          2 monitors (0, 0, 2560, 1024): (0, 0, 1280, 1024), 32 bpp; (1280, 0, 2560, 1024), 32 bpp

          Thank you for this version information. As you may have noticed, Tools
          is updated quite often so it's helpful to know the specific versions of
          different components.

          Previewing...could be...good question...I'm
          copying/pasting/previewing/closing/opening so fast I wasn't paying
          attention. BUT, I was going to ask about the PREVIEW files that
          showed up in the directory where I store the files I create. I
          assumed that was a feature and tried to find a way to turn it off.
          Now I'm thinking they aren't supposed to be there.

          I erased them all so I can't tell you anymore about them. I will send
          you one of the files I was working on.

          Thank you, Chami!

          Deleting these temporary preview files may cause a problem because
          preview windows expect them to be there for the duration.

          When you preview a document that hasn't been saved, Tools creates a
          temporary preview file. You can turn this off, but then you'll have to
          save the document each time to get an accurate preview.

          You don't have to (and generally shouldn't) manually delete temporary
          preview files because they're automatically removed either when you
          close the document or when you exit Tools.

          I just heard a ding... and it's your email with the attachment. Thanks
          again! I'll go see if I can reproduce this.

          Chami

          • SaintRoch, 25th Jun 2012 5:23 pm

            I didn't erase the preview files until later, after I exited the application.

            If I understand you correctly, they should not have been there after I exited the program.

            I wouldn't normally delete files while I am still in the application...

            I'll see if I can reproduce it too!

            Thanks a lot.

            • HTML-Kit Support, 26th Jun 2012 12:24 am

              On 6/25/2012 5:23 PM, SaintRoch wrote:

              I didn't erase the preview files until later, after I exited the
              application.

              Ahh... I see.

              If I understand you correctly, they should not have been there after
              I exited the program.

              I wouldn't normally delete files while I am still in the
              application...

              I'll see if I can reproduce it too!

              Thanks a lot.

              These preview files should have gotten removed, unless the preview
              didn't properly exit. So this is sounding more and more like a preview
              related problem. Let me play with it a little bit more and then I'll
              post a test version to verify this one way or the other.

              Thanks again.

              Chami

              • SaintRoch, 26th Jun 2012 9:42 am

                Thank you for all your help on this.

                Don't go too crazy...the preview files have not shown up again - although I haven't been editing - just OPEN, COPY, PASTE - previewed a couple.

                It is POSSIBLE that the other day when I had the problem I was saving while in preview mode. It was only happening after every 5th or 6th file I opened, edited, saved and closed. It was rote work so my fingers were moving more quickly than my brain.

                Thanks again.

                • HTML-Kit Support, 27th Jun 2012 3:52 pm

                  On 6/26/2012 9:42 AM, SaintRoch wrote:

                  Thank you for all your help on this.

                  Don't go too crazy...the preview files have not shown up again -
                  although I haven't been editing - just OPEN, COPY, PASTE - previewed
                  a couple.

                  It is POSSIBLE that the other day when I had the problem I was saving
                  while in preview mode. It was only happening after every 5th or 6th
                  file I opened, edited, saved and closed. It was rote work so my
                  fingers were moving more quickly than my brain.

                  Thanks again.

                  Thanks again for the follow-up. I won't go too crazy :)

                  The next test version is almost ready and I hope to post it later today
                  or tomorrow. If you feel like checking it out, I've enabled TreeHouse
                  test versions in your User Assistant account. No worries if you rather
                  not play with test versions though. These updates will be available in
                  the next general release.

                  Chami

                  • SaintRoch, 28th Jun 2012 10:48 am

                    Hi Chami-

                    I duplicated the problem. I just hope I can explain it accurately.

                    I have 35 item with 99% the same code. When I make changes I open the 1st file, edit it, then use it as a template for the others.

                    IOW, I open APPLE. Change it, preview it, and save it.

                    Then I change it again, preview it, and SAVE AS APRICOT.

                    Then I change it again, preview it, and SAVE AS AQUAMARINE.

                    And so on...

                    This morning I noticed that when I saved as APRICOT, the APPLE preview was still in the directory. That continued to be true - all the previews stayed there as I moved from file to file.

                    When I got to KELLY GREEN, about 15+ files altogether, I noticed when I save as that there was no preview for the previous file, ISLAND PINK, in the directory. I wondered if I had saved the new version over the old, so I selected ISLAND PINK to check it (while KELLY GREEN was still open), previewed ISLAND PINK finding it was in fact correct, and I (believe) I hit the X to close the ISLAND PINK file. That's when the crash occurred.

                    I checked the directory after the crash and the preview files are all still there - except for the ones for ISLAND PINK and KELLY GREEN.

                    Hope this helps.


                    BTW even at my simple need level the full version is so much nicer to work with. Thanks!

                    • HTML-Kit Support, 28th Jun 2012 11:56 am

                      On 6/28/2012 10:48 AM, SaintRoch wrote:

                      Hi Chami-

                      I duplicated the problem. I just hope I can explain it accurately.

                      I have 35 item with 99% the same code. When I make changes I open the
                      1st file, edit it, then use it as a template for the others.

                      IOW, I open APPLE. Change it, preview it, and save it.

                      Then I change it again, preview it, and SAVE AS APRICOT.

                      Then I change it again, preview it, and SAVE AS AQUAMARINE.

                      And so on...

                      This morning I noticed that when I saved as APRICOT, the APPLE
                      preview was still in the directory. That continued to be true - all
                      the previews stayed there as I moved from file to file.

                      When I got to KELLY GREEN, about 15+ files altogether, I noticed when
                      I save as that there was no preview for the previous file, ISLAND
                      PINK, in the directory. I wondered if I had saved the new version
                      over the old, so I selected ISLAND PINK to check it (while KELLY
                      GREEN was still open), previewed ISLAND PINK finding it was in fact
                      correct, and I (believe) I hit the X to close the ISLAND PINK file.
                      That's when the crash occurred.

                      I checked the directory after the crash and the preview files are all
                      still there - except for the ones for ISLAND PINK and KELLY GREEN.

                      Hope this helps.

                      I appreciate the detailed steps! Always nice to have when troubleshooting :)

                      I repeated your steps (hopefully correctly) and did see that
                      preview_apple.html, preview_apricot.html and so on stayed in the
                      directory as I changed file name using save-as. When I closed the file
                      though, the current preview file as well all previous preview_*.html
                      files got removed. This may not have happened in your case because the
                      last preview crashed before it had a chance to clean up temp files.

                      However, there's no technical reason to keep apple and apricot preview
                      files until the file is closed, once the file is renamed to aquamarine.
                      I'll work on that part.

                      At least in this round I wasn't able to produce a crash I'm afraid. I'll
                      keep an eye out for this case though, now that I understand the steps.
                      Also, if you'd like, you can grab the TreeHouse build from your User
                      Assistant account to see if you can reproduce a crash with the latest
                      version.


                      BTW even at my simple need level the full version is so much nicer to
                      work with. Thanks!

                      Oh thank you for the kind words! Please keep posting your feedback and
                      let's see if we can't make it work even better :)

                      Chami

                    • HTML-Kit Support, 5th Jul 2012 4:54 pm

                      On 6/28/2012 10:48 AM, SaintRoch wrote:

                      Hi Chami-

                      I duplicated the problem. I just hope I can explain it accurately.
                      ...

                      Hi,

                      I don't know if you've had a chance to play with any of the TreeHouse
                      builds but if you have and still having any problems previewing, please
                      let me know. I'll try again to reproduce it. Otherwise this latest
                      TreeHouse build will most likely become the next general release.

                      Thanks again!

                      Chami