Extended Preview?

  • Advertisement ( why? )
     

    DesktopboB, 26th Sep 2013 4:19 pm

    Chami,
    I'm trying to get Extended Preview up and running.
    I"m using Treehouse 20130902.

    I can get the Extended Preview started in both XP and Win 7 (running as administrator) and can view the page in all browsers.

    The problems start when I try to view the page on my tablet.
    I have an ASUS Transformer that is running Android 4.2.1.
    Both Firefox and Chrome are up to date on the tablet.

    When I attempt to preview the page on the tablet, I enter the address shown in the Extended Preview window that opens in Tools.
    Then, in either Chrome or Firefox, things spin for awhile and then I'm told that the site is taking too long to respond.

    I am on the same network for all my devices.

    I've even tried hitting F12 while the page is trying to load (before it times out), but that seems to offer no joy.

    Any ideas?

    Thanks,
    boB

    • HTML-Kit Support, 26th Sep 2013 4:37 pm

      On 9/26/2013 4:19 PM, DesktopboB wrote:

      Chami,
      I'm trying to get Extended Preview up and running.
      I"m using Treehouse 20130902.

      I can get the Extended Preview started in both XP and Win 7 (running
      as administrator) and can view the page in all browsers.

      The problems start when I try to view the page on my tablet.
      I have an ASUS Transformer that is running Android 4.2.1.
      Both Firefox and Chrome are up to date on the tablet.

      When I attempt to preview the page on the tablet, I enter the address
      shown in the Extended Preview window that opens in Tools.
      Then, in either Chrome or Firefox, things spin for awhile and then
      I'm told that the site is taking too long to respond.

      I am on the same network for all my devices.

      I've even tried hitting F12 while the page is trying to load (before
      it times out), but that seems to offer no joy.

      Any ideas?

      Thanks,
      boB

      Hey boB,

      First, yay on trying out Extended Preview on your tablet!

      If you can use Extended Preview from multiple browsers on your computer
      but not from a tablet-like device, that usually means that something is
      blocking the connection and most likely it's the firewall on the PC.

      So just to see if that's in fact the case, temporary disable the
      firewall on the PC and refresh browser on the tablet. Enable the
      firewall again. If it worked (and it should have), then go back to the
      firewall and make sure that it's allowing connections on *:port shown on
      Extended Preview window.

      Let me know how it goes.

      Chami

      • DesktopboB, 27th Sep 2013 1:25 pm

        Chami,
        Thanks for pointing me in the right direction.
        Got things working on both machines and I'm including the steps I took for both XP and Win 7...feel free to use the steps if you would like (just give me a byline...LOL!).

        First, I should mention I sort of skipped as step. I went straight into disabling the firewall and then trying to access the Extended Preview. Worked like a charm and, once the firewall was re-enabled, the Extended Preview failed.

        Using Windows XP with SP3
        Settings-->Control Panel --> Windows Firewall
        Choose the Exceptions tab
        Choose Add Port
        Type in a description of some sort and enter the port number that shows in the Extended Preview window
        Hit OK and OK
        Enter the Extended Preview address in the browser of your device and you're good to go!

        Messed around a whole bunch with Windows 7 SP1 and you need an effing degree in computer science to get this done and even my favorite computer science degree fallback, Google, was only partial help.
        In any event, the key is to make an Inbound Rule as described below (this would seem rather counter-intuitive, since it would seem Tools in "sending" out the pages, but I tried both Outbound and Inbound and Inbound is the one that works).

        Using Windows 7 Home Premium Sp !
        Open Control Panel --> Windows Firewall
        Select Advanced Settings
        In the panel on the left select Inbound Rules
        In the panel on the right, select New Rule
        This opens a wizard
        Select Port
        Hit Next
        Choose TCP and then selct Specific Remote Port
        Type in the number of the port as it shows in Extended Preview
        Hit Next
        Select Allow the Connection
        Hit Next
        The next window is a bit of mystery meat, but I selected all the options
        Hit Next
        Chose whatever text you wish as a name and then added the description of your choice.
        All should now be well and you can enter the Extended Preview address in the browser of your device and F12 updates the view.

        Time for lunch.

        boB

        • HTML-Kit Support, 30th Sep 2013 4:24 pm

          On 9/27/2013 1:25 PM, DesktopboB wrote:

          Chami,
          Thanks for pointing me in the right direction.
          Got things working on both machines and I'm including the steps I
          took for both XP and Win 7...feel free to use the steps if you would
          like (just give me a byline...LOL!).

          First, I should mention I sort of skipped as step. I went straight
          into disabling the firewall and then trying to access the Extended
          Preview. Worked like a charm and, once the firewall was re-enabled,
          the Extended Preview failed.

          Using Windows XP with SP3
          Settings-->Control Panel --> Windows Firewall
          Choose the Exceptions tab
          Choose Add Port
          Type in a description of some sort and enter the port number that
          shows in the Extended Preview window
          Hit OK and OK
          Enter the Extended Preview address in the browser of your device and
          you're good to go!

          Messed around a whole bunch with Windows 7 SP1 and you need an
          effing degree in computer science to get this done and even my
          favorite computer science degree fallback, Google, was only partial
          help.
          In any event, the key is to make an Inbound Rule as described below
          (this would seem rather counter-intuitive, since it would seem Tools
          in "sending" out the pages, but I tried both Outbound and Inbound
          and Inbound is the one that works).

          Using Windows 7 Home Premium Sp !
          Open Control Panel --> Windows Firewall
          Select Advanced Settings
          In the panel on the left select Inbound Rules
          In the panel on the right, select New Rule
          This opens a wizard
          Select Port
          Hit Next
          Choose TCP and then selct Specific Remote Port
          Type in the number of the port as it shows in Extended Preview
          Hit Next
          Select Allow the Connection
          Hit Next
          The next window is a bit of mystery meat, but I selected all the
          options
          Hit Next
          Chose whatever text you wish as a name and then added the
          description of your choice.
          All should now be well and you can enter the Extended Preview address
          in the browser of your device and F12 updates the view.

          Time for lunch.

          boB

          Nice! I'm sure others will find your detailed steps useful.

          An inbound rule is required here because the device doing the preview
          has to load images and other resources from HTML-Kit. It's binding to a
          192.*-type local IP within your LAN.

          Thanks boB.

          Chami