Colorizer question

  • Advertisement ( why? )
     

    ITGroup, 7th Mar 2014 1:00 pm

    I use HTML-Kit for HTML authoring and recently I've got serious about learning to improve my workspace using the colorizer.

    Everything seems to work as expected except for the = sign. It is black and does not obey the colorizer settings for attributes which is #87C895
    How can I make it same as those settings?
    Here are my colorizer settings:

    <type name="html,xml,php,asp,aspvb,aspjs">

    <group name="HTML" foreground="green">
    <item n="default" f="#AFDFDF" b="#003333" fontstyle="N"/>
    <item n="tag" f="#87C895" b="#003333"/>
    <item n="tag_undefined" f="#87C895" b="#003333"/>
    <item n="tag_end" f="#87C895" b="#003333" />
    <item n="attr" f="#87C895" fontsize="-1" b="#003333"/>
    <item n="attr_undefined" f="#87C895" b="#003333" />
    <item n="attr_value" f="#87C895" fontsize="-1" b="#003333"/>
    <item n="attr_value_number" f="#87C895" b="#003333"/>
    <item n="attr_value_other" f="#87C895" b="#003333"/>
    <item n="string_doubleq" f="#87C895" fontsize="-1" b="#003333" />
    <item n="string_singleq" f="#87C895" b="#003333" />
    <item n="entity" f="#B404AE" b="#003333"/>
    <item n="cdata" f="#87C895" b="#003333" />
    <item n="comment" f="green" fontsize="-1" />
    <item n="comment_x" f="green" fontsize="-1" />
    <item n="xml_start" f='#87C895' b="#003333" />
    <item n="xml_end" f='#87C895' b="#003333" />
    </group>

    • ITGroup, 13th Mar 2014 5:17 pm

      I solved this issue by installing CopenhagenNights style and working backwards.

      Now my problem is how to colorize a file type that is not recognized. In my case I am editing a .dox file which is a text file that is associated with Doxygen

      • rodfarias, 14th Mar 2014 7:29 am

        Hello ITGroup.

        If the .dox syntax is similar to html (tag, attr, comment...), do the following:

        Menu > Edit > Preferences > Files
        Find in "File Types" the "HTML, XHTML" section (the first).
        At the end of the section list, click on "Edit...".
        Append "dox" extension and click OK.
        Save the preferences.
        Probably restart Html-Kit.

        If the dox syntax does not look like to html it will not be used, you should look for another type and group in the example styles.

        If you want set the background style, add an " * " item to the group, like this:

        <colorizer>

        <type name="html">

        <group name="html" f="green">
        <item n="*" b="#003333" />
        <item n="html" fontsize="-1" f="#87C895" b="#003333" />
        <item n="attr" fontsize="-1" f="#87C895" b="#003333" />
        <item n="tag" f="#87C895" b="#003333"/>
        <item n="default" f="#87C895" b="#003333" fontstyle="N"/>
        <item n="string_doubleq" f="#87C895" fontsize="-1" b="#003333" />
        <item n="string_singleq" f="#87C895" b="#003333" />
        <item n="entity" f="#B404AE" b="#003333"/>
        <item n="cdata" f="#87C895" b="#003333" />
        <item n="comment" f="green" fontsize="-1" />
        <item n="comment_x" f="green" fontsize="-1" />
        <item n="xml_start" f='#87C895' b="#003333" />
        <item n="xml_end" f='#87C895' b="#003333" />
        </group>

        </type>
        </colorizer>

        Sorry bad english, blame it on Google translator.

        Rodrigo