Cannot find template file/reference not specified

  • Advertisement ( why? )
     

    Poirot, 1st Nov 2012 8:09 am

    Since I upgraded my TOOLS to v 20120815 my HTML files that are based on fluid templates do not update anymore when I click the 'update now' link below the file.
    I get the following error box:

    Error: Could not find template "#template_name"
    Error: template file /reference not specified in "<-- template: begin ref="template_name"

    I have not changed anything else, so I got no idea why it is doing this.

    Also, whenever I start TOOLS, my computer freezes for about 5 minutes, and then I get an error that I am out of memory. Usually everything loads a bit later, and I learned by now to go and make a cup of tea after I started the program.
    I have quite a few large projects that automatically load, and maybe that is the problem. Can I turn off the loading of all projects automatically and only choose to load that project I want to work on?

    Cheers

    John

    • HTML-Kit Support, 1st Nov 2012 8:23 am

      On 11/1/2012 8:09 AM, Poirot wrote:

      Since I upgraded my TOOLS to v 20120815 my HTML files that are based
      on fluid templates do not update anymore when I click the 'update now'
      link below the file.
      I get the following error box:

      Error: Could not find template "#template_name"
      Error: template file /reference not specified in "<-- template: begin ref="template_name"

      I have not changed anything else, so I got no idea why it is doing this.

      Also, whenever I start TOOLS, my computer freezes for about 5
      minutes, and then I get an error that I am out of memory. Usually
      everything loads a bit later, and I learned by now to go and make a
      cup of tea after I started the program.
      I have quite a few large projects that automatically load, and maybe
      that is the problem. Can I turn off the loading of all projects
      automatically and only choose to load that project I want to work
      on?

      Cheers

      John

      Hi John,

      Tools in general shouldn't take longer to start. In fact, it should be
      loading faster than previous builds. What usually takes up time during
      startup is, as you've guessed, auto loading projects specially if
      there's a pointer to a file on a network or other slower media. You can
      disable auto loading projects under "Edit > Preferences > General >
      Reopen projects." If "Reopen files" is checked, turning it off may also
      help.

      As for fluid templates, I don't remember making any changes to it. If
      there's a quick sample you can email me I'll be glad to check it out:
      htmlkit.com/contact/

      Hope this helps.

      Chami

      • Poirot, 1st Nov 2012 4:50 pm

        Wow, what a difference that makes, turning off the auto-loading. I did not even get to the teabag!
        Chami, I also sent you a file and the relevant email by email.

        Thanks

        John

        • Poirot, 1st Nov 2012 5:06 pm

          STOP THE PRESS:
          It suddenly all works again. Since I turned off the auto-loading of projects, I no longer get the error and everything is working as it is supposed to.
          It maybe had something to do with memory as a result of loading to many files?
          Anyway, all good :)

          • HTML-Kit Support, 2nd Nov 2012 1:07 pm

            On 11/1/2012 5:06 PM, Poirot wrote:

            STOP THE PRESS:
            It suddenly all works again. Since I turned off the auto-loading of
            projects, I no longer get the error and everything is working as it
            is supposed to.
            It maybe had something to do with memory as a result of loading to
            many files?
            Anyway, all good :)

            I replied by email but glad to hear that things are back to normal :)

            Chami