Can't create new file using templates

  • Advertisement ( why? )
     

    ginerjm, 19th Jul 2012 9:31 pm

    Working on a new pc now with w7. First attempt to create a new file in HTML-Kit Tools (V20120605) and when I select a template to use I get the following error dialog box:

    Could not find executable: php.exe

    Ideas?

    • ginerjm, 19th Jul 2012 9:58 pm

      After a little trial and error, I find that I can open the built-in templates, but not all of my own.

      • HTML-Kit Support, 19th Jul 2012 11:04 pm

        On 7/19/2012 9:58 PM, ginerjm wrote:

        After a little trial and error, I find that I can open the built-in
        templates, but not all of my own.

        Hi,

        Are your custom templates using PHP? If they're static templates they
        won't require PHP.

        If you create a new template ("File > New > Add new template") and keep
        "Default" as the "Plugin language" they shouldn't require PHP to run.

        Let me know if this doesn't work.

        Chami

        • ginerjm, 21st Jul 2012 10:27 am

          Yes the template has php code in it. Don't recall ever changing any language setting when I made this - I was new at the time.

          Anyway - I solved this problem by adding c:\php to my registry's 'path'.

          btw - any idea why my new W7/IE9 machine won't allow me to post this response without first going to Develope Tools and setting it to IE8 compatibility first?

          • HTML-Kit Support, 22nd Jul 2012 1:08 am

            On 7/21/2012 10:27 AM, ginerjm wrote:

            Yes the template has php code in it. Don't recall ever changing any
            language setting when I made this - I was new at the time.

            Anyway - I solved this problem by adding c:\php to my registry's
            'path'.

            I'm glad you were able to solve this.

            Unless a template is a PHP plugin (for HTML-Kit), php.exe isn't required
            to insert templates.

            btw - any idea why my new W7/IE9 machine won't allow me to post this
            response without first going to Develope Tools and setting it to IE8
            compatibility first?

            I haven't had any problem posting to the forum with IE 9 in Windows 7.
            What kind of error are you getting?

            Chami